10 ago. 2021

Graves vulnerabilidades en productos Cisco

Esta semana Cisco ha lanzado diversos parches para solucionar vulnerabilidades en varios de sus productos que podrían permitir la ejecución de código arbitrario o de comandos en los dispositivos afectados, entre otros.

Cisco ha publicado varios boletines de seguridad para varios de sus productos. De entre todos ellos, destaca la vulnerabilidad CVE-2021-1609 por ser de la mayor gravedad. Ha sido clasificada como crítica por la propia compañia y se le ha asignado una valoración CVSS de 9.8 sobre 10. Se trata de un fallo de seguridad debido a una incorrecta validación de las peticiones HTTP en la interfaz web de administración de los enrutadores Dual WAN Gigabit VPN modelos RV340, RV340W, RV345 y RV345P. Dicho error podría permitir a un atacante remoto no autenticado ejecutar código arbitrario o causar una condición de denegación de servicio (DoS) a través del envío de peticiones HTTP.

>Dicha interfaz de administración web es accesible localmente de manera predeterminada y no se puede deshabilitar. Por otra parte, aunque el acceso remoto debe ser configurado por el usuario y se encuentra desactivada por defecto, se ha podido comprobar la existencia de más de 8.800 dispositivos accesibles de forma remota.

Una segunda vulnerabilidad en los mismos dispositivos, la CVE-2021-1610, podría permitir la inyección de comandos arbitrarios con privilegios de root. Esta es debida también a un fallo en la interfaz web de administración y su explotación es similar a la anterior, aunque en este caso sí que se requiere de autenticación. Este hecho hace que sea considerada "solamente" como de alta gravedad, con una puntuación CVSS de 7.2.

Cisco también ha liberado parches para las siguientes vulnerabilidades de alta gravedad que afectan a otros productos y dispositivos:

  • CVE-2021-1602: un problema de ejecución remota de comandos con privilegios de root en los enrutadores VPN RV160, RV160W, RV260, RV260P y RV260W debido a una validación insuficiente de las entradas proporcionadas por el usuario en la interzar web de administración. Esta vulnerabilidad sería explotable sin necesidad de autenticación, sin embargo solo sería posible ejecutar comandos sin parámetros, evitando que sea considerada una vulnerabilidad crítica.
  • CVE-2021-1593: un fallo en el manejo de las rutas de directorios en tiempo de ejecución en Packet Tracer para Windows que podría permitir un ataque de inyección de DLL por parte de un atacante local sin autenticar.
  • CVE-2021-1572: vulnerabilidad que afecta a Cisco Network Services Orchestrator (NSO) y ConfD. Se debe a la incorrecta ejecución del servicio de usuario SFTP con el nivel de privilegio de la cuenta que se estaba utilizando cuando se habilitó el servidor Secure Shell (SSH) integrado. Esto podría permitir a un atacante local autenticado ejecutar comandos arbitrarios con los permisos de la cuenta bajo la cual se ejecuta Cisco NSO o ConfD (root de forma predeterminada).

Los parches para todas las vulnerabilidades expuestas anteriormente se encuentran disponibles en la página oficial de Cisco y para descargar a través de los canales habituales.

Fuente: Hispasec

Suscríbete a nuestro Boletín

0 Comments:

Publicar un comentario

Gracias por dejar un comentario en Segu-Info.

Gracias por comentar!