14 abr. 2021

Zero-Day para vulnerabilidad RCE en Chrome, Edge, Opera y Brave (Parchea YA!)

Era un secreto a voces que circulaba por foros y grupos "privados". La explotación funciona en cualquier navegador basado en Chromium (sin actualizar) y en cualquier sistema operativo.

El investigador indio Rajvardhan Agarwal publicó un exploit de una vulnerabilidad que permite ejecución remota de código (RCE) en el motor de renderizado de JavaScript V8 de Chromium, en el que se basan los navegadores web Chomre, Microsoft Edge, Opera y Brave.

Es la misma falla demostrada por Bruno Keith y Niklas Baumstark de Dataflow Security en el concurso de hacking Pwn2Own 2021 la semana pasada y que fue recompensado con un premio de 100.000 dólares.

La PoC ejecutada en un navegador vulnerable produce la ejecución de la calculadora de Windows. Sin embargo se remarca la necesidad de complementar este exploit con un mecanismo para escapar la sandbox para poder utilizarlo (por ejemplo, con -no-sandbox).

Al parecer, el investigador fue capaz de desarrollar la prueba de concepto tras analizar el parche incorporado al repositorio de Chromium. Google ha abordado el problema en la última versión de V8 y, si bien se espera que Google publique Chrome 90, mientras tanto es importante actualizar a Chromium 89.0.4389.128 en cualquier navegador.

Fuente: THN | r4j0x00

Suscríbete a nuestro Boletín

0 Comments:

Publicar un comentario

Gracias por dejar un comentario en Segu-Info.

Gracias por comentar!