6 feb. 2021

Vulnerabilidades de XSS, SQLi y DoS en FortiWeb (Parchea!)

Fortinet ha solucionado varias vulnerabilidades en los firewalls de aplicaciones web FortiWeb que fueron reportadas por el experto en Positive Technologies, Andrey Medov.

La primera vulnerabilidad, identificada como CVE-2020-29015, es una Blind SQL Injection que reside en la interfaz de usuario de FortiWeb. Un atacante no autorizado podría aprovechar la falla para ejecutar de forma remota consultas SQL arbitrarias enviando una solicitud con un encabezado de autorización que contenga un comando SQL malicioso. La falla recibió una puntuación CVSS de 6.4/10.

Medov también encontró dos problemas de buffer overflowde identificados como CVE-2020-29016 y CVE-2020-29019, ambos recibieron una puntuación CVS de 6.4. El primero podría ser aprovechado por un atacante remoto no autorizado para sobrescribir el contenido de la pila y ejecutar código arbitrario enviando una solicitud con un parámetro GET "certname" generado especialmente.

Los atacantes pueden aprovechar la vulnerabilidad CVE-2020-29019 para montar un ataque DoS en el sobre httpd mediante una solicitud con un parámetro de cookie especialmente generado.

La cuarta vulnerabilidad, identificada como CVE-2020-29018, es una vulnerabilidad de validación en el formato de cadena que permite a atacantes remotos leer el contenido de la memoria, obtener datos confidenciales y ejecutar código o comandos no autorizados utilizando el parámetro "redir". La falla recibió una puntuación CVSS de 5.3, se solucionó con el lanzamiento de FortiWeb versión 6.3.6.

"Las más peligrosas de estas cuatro vulnerabilidades son SQL Injection (CVE-2020-29015) y Buffer Overflow (CVE-2020-29016) ya que su explotación no requiere autorización. El primero permite obtener el hash de la cuenta del administrador del sistema debido a privilegios de usuario excesivos de DBMS, lo que le da acceso a la API sin descifrar el valor del hash. El segundo permite la ejecución de código arbitrario. Además, la vulnerabilidad de cadena de formato (CVE-2020-29018) también puede permitir la ejecución de código, pero su explotación requiere autorización" dijo Andrey Medov de Positive Technologies. 

Por último se han solucionado 4 vulnerabilidades de XSS, identificadas como CVE-2021-22122 y con un puntaje de 4.6/10.

Los clientes que utilizan FortiWeb 6.3.x y 6.2.x deben actualizar a las versiones 6.3.8 y 6.2.4 o superior.

Fuente: Positive Technology

Suscríbete a nuestro Boletín

0 comentarios:

Publicar un comentario

Gracias por dejar un comentario en Segu-Info.

Gracias por comentar!