19 may. 2020

BIAS: vulnerabilidad de Bluetooth afecta a todos los dispositivos

Investigadores de la École Polytechnique Fédérale de Lausanne (EPFL) han encontrado una vulnerabilidad en el protocolo Bluetooth que afecta a todos los dispositivos que lo usan en la actualidad, de los cuales hay miles de millones en el mercado.

Los investigadores han bautizado la vulnerabilidad como BIAS (Bluetooth Impersonation Attacks), donde es necesario estar próximo al dispositivo atacado para poder establecer una conexión, además de que el atacante debe haber realizado una conexión previa con ese dispositivo; o al menos conocer una dirección de un dispositivo ya emparejado.

Cualquier atacante puede conectarse a tu móvil con BIAS

Así, los investigadores afirman que es posible que un atacante pueda realizar spoofing con una dirección previamente asociada a un dispositivo para completar el proceso de autenticación sin tener que utilizar la clave de enlace, pudiendo realizar incluso un ataque de Key Negotiation of Bluetooth (KNOB).

El fallo radica concretamente en la forma en la que dos positivos previamente emparejados entre sí gestionan la clave que los une a largo plazo. Esta clave se utiliza para autenticar los dispositivos y activar una conexión segura entre ellos, evitando tener que realizar un emparejamiento desde cero cada vez que conectamos por ejemplo unos auriculares Bluetooth al móvil. Con el ataque KNOB, el atacante puede ir un paso más allá y obtener la clave de la sesión al rebajar la seguridad de la conexión y tener acceso completo como cualquier otro dispositivo conectado sin que el usuario atacado tenga que hacer nada. En el siguiente vídeo podemos ver cómo funciona.

El Bluetooth SIG afirma que han actualizado la especificación del estándar Bluetooth para solucionar el fallo, y recomiendan comprobar el cifrado usado en las conexiones para evitar que se produzcan downgrades en el cifrado utilizado a protocolos más antiguos e inseguros. Este último cambio también se introducirá en la próxima especificación del estándar, pero en la actual de momento no lo está.

Vulnerabilidad parcheada desde diciembre de 2019

Así, la recomendación para solucionar el fallo es que los fabricantes eviten que se produzcan una reducción de la longitud de la clave de cifrado por debajo de 7 octetos. Además, también recomiendan que se realice autenticación mutua al realizar conexiones con dispositivos antiguos, que sólo se soporten conexiones seguras cuando sea posible, y que la autenticación de la conexión no se use para indicar de manera independiente un cambio en el estado de confianza del dispositivo sin antes requerir el establecimiento de un enlace cifrado entre ambos.

La única solución que tenemos para protegernos es que el fabricante de nuestro dispositivo o sistema operativo lance una actualización de seguridad que solucione el fallo. Todos los dispositivos que hayan recibido un parche de seguridad posterior a diciembre de 2019 están protegidos, y si no lo han recibido, son vulnerables. Los investigadores probaron el ataque en 30 dispositivos distintos, incluyendo móviles, tablets, auriculares, ordenadores e incluso una Raspberry Pi, y todos son vulnerables al ataque.

Fuente: Bluetooth SIG

0 comentarios:

Publicar un comentario

Gracias por dejar un comentario en Segu-Info
Si vas a dejar una consulta, procura tener habilitado tu perfil en Blogger o deja una forma de contacto.

Gracias por comentar!