4 ago. 2016

Vulnerabilidad de 20 años, permite robar credenciales en Windows

Descubierta en 1997 por Aaron Spangler y nunca arreglada, la vulnerabilidad de autenticación automática en Win95/WinNT (IE Bug #4) es sin duda una de las vulnerabilidades más curiosas de Windows. Tal y como adelantamos ayer, existe el mismo error en Windows 8/10, y podría utilizarse para robar hash de Microsoft Live, OneDrive, Outlook, Office, Mobile, Bing, Xbox Live, MSN y Skype (si se usa con una cuenta de Microsoft) y cualquier otro tipo de cuenta relacionada a un dominio o VPN.

Si bien el error es el mismo desde Windows 95/NT, sólo se ven afectados Windows 8 y superiores y para comprobarlo se puede ejecutar la demostración pública de la explotación (en IE), basado en el trabajo original de ValdikSS publicado ayer aquí mismo.
Básicamente, la autentificación de Edge/Spartan (y también Internet Explorer, Outlook) permite al explorador conectarse a recursos compartidos de la red local, pero erróneamente no se bloquean las conexiones a recursos compartidos remotos a través del protocolo SMB.

Para explotarlo, un atacante simplemente crea un enlace que apunte a ese recurso compartido de red y se lo a la víctima, por ejemplo como parte de un correo electrónico o sitio web. Cuando la víctima visualiza el contenido en Edge, Internet Explorer o Outlook, tratará de conectar a ese recurso y silenciosamente se enviarán los datos inicio de sesión de Windows: el nombre de usuario en texto plano y el hash NTLMv2 de la contraseña.

Aunque la discusión original se conoce desde hace más de dos décadas, su gravedad se comienza a conocer últimamente. En 1997, el atacante sólo habría obtenido datos de inicio de sesión locales de Windows, pero en Windows 10, el método de inicio de sesión predeterminado es la cuenta de usuario global de Microsoft Live y además un atacante puede tener recurrir al crackeo del hash NTLM y acceder de forma remota a la red.

Por ahora, Firefox y Chrome no se ven afectados. Los investigadores sugieren que los usuarios de Windows 8/10 configuren correctamente el para protegerse de estos ataques.

Fuente: HackaDay | gHacks

0 comentarios:

Publicar un comentario

Gracias por dejar un comentario en Segu-Info
Si vas a dejar una consulta, procura tener habilitado tu perfil en Blogger o deja una forma de contacto.

Gracias por comentar!