23 ene. 2019

Vulnerabilidad en el firmware para chips Wi-Fi afecta a millones de dispositivos

Se informa de una vulnerabilidad que afecta al firmware de una serie de chips Wi-Fi. Esta vulnerabilidad ha sido descubierta por un grupo de investigadores de seguridad y afecta a ThreadX. ThreadX es el Sistema Operativo en Tiempo Real (RTOS) que es utilizado como firmware en millones de dispositivos en todo el mundo. Por este motivo esta vulnerabilidad es de gran importancia. Puede afectar a millones de usuarios en todo el planeta.

Estos investigadores de seguridad han explicado que un posible atacante podría explotar la vulnerabilidad del firmware ThreadX. Hicieron una prueba con un chip Wi-Fi instalado en un Marvell Avastar 88W8897. Lograron ejecutar el código malicioso sin la interacción del usuario. En Marvell System-on-Chip (SoC) hay ciertos controladores que funcionan con el kernel de Linux que usa: "mwifiex" (fuente disponible en el repositorio oficial de Linux), "mlan" y "mlinux", cuyas fuentes están disponibles en el repo de steamlink-sdk.
No es casualidad que los investigadores de seguridad eligieran este chip en concreto. La razón es porque es muy popular y es utilizado en numerosos dispositivos en todo el mundo. Marvell Avastar 88W8897 SoC (Wi-Fi + Bluetooth + NFC), está presente en Sony PlayStation 4 (y Pro), Microsoft Surface (+Pro) tablet y laptop, Xbox One, Samsung Chromebook, Galaxy J1, y Valve SteamLink

Según indica uno de los investigadores de seguridad, han logrado identificar 4 problemas de corrupción de memoria en algunas partes del firmware. Una de estas vulnerabilidades puede activarse sin la interacción del usuario al realizar una búsqueda de redes.

Envía paquetes Wi-Fi con formato incorrecto

La función de firmware para buscar nuevas redes Wi-Fi se inicia automáticamente cada cinco minutos. Lo que hace el atacante es enviar paquetes Wi-Fi con formato incorrecto a cualquier dispositivo que cuenten con este tipo de chips con la vulnerabilidad. Posteriormente solo tienen que esperar hasta que se inicie la función y desplegar código malicioso para controlar el dispositivo.

Informan que esta vulnerabilidad que afecta a ThreadX podría estar presente en más de 6.000 millones de dispositivos. Como vemos, puede afectar a muchos usuarios en todo el mundo.

Podemos acceder al informe completo de esta vulnerabilidad. Lógicamente el código de prueba de concepto no se ha publicado.

En definitiva, una importante vulnerabilidad afecta a miles de millones de dispositivos en todo el mundo. Concretamente afecta a los chips Wi-Fi que están dentro. Son muchos los tipos de dispositivos que pueden sufrir este problema.

Fuente: RedesZone

0 comentarios:

Publicar un comentario

Gracias por dejar un comentario en Segu-Info
Si vas a dejar una consulta, procura tener habilitado tu perfil en Blogger o deja una forma de contacto.

Gracias por comentar!