2 abr. 2018

Bugs críticos en Cisco IOS afecta al 8,5 millones de dispositivos (Parchea!)

Cisco ha publicado parches para 34 vulnerabilidades que afectan principalmente a su software de red IOS e IOS XE, incluidos tres errores críticos que permitirían ejecución de código.
Tal vez el problema más serio es la vulnerabilidad identificada como CVE-2018-0171 que afecta a Smart Install, un cliente de Cisco que permite la instalación rápida de nuevos switches. Un atacante remoto no autenticado puede explotar esta falla en el cliente y causar una denegación de servicio o ejecutar código arbitrario.

Embedi, la empresa de seguridad que encontró la falla, inicialmente creyó que solo podía ser explotada dentro de la red de la empresas. Sin embargo, encontró millones de dispositivos afectados expuestos en Internet. "En una red configurada de forma segura, no se debe poder acceder a los participantes de la tecnología Smart Install a través de Internet. Pero una búsqueda en Internet ha demostrado que esto no es cierto", escribió Embedi. "Durante un breve análisis de Internet, detectamos 250.000 dispositivos vulnerables y 8,5 millones de dispositivos que tienen un puerto vulnerable abierto".

Smart Install es compatible con una amplia gama de ruters y switches Cisco. La gran cantidad de dispositivos con un puerto abierto probablemente se deba a que el puerto del cliente de instalación inteligente TCP 4786 está abierto de manera predeterminada.
Embedi descubrió la falla el año pasado, obteniendo un premio en la conferencia GeekPwn en Hong Kong en mayo pasado, y se lo comunicó a Cisco en septiembre [PDF]. Un atacante puede explotar el error enviando un mensaje Smart Install a estos dispositivos en el puerto TCP 4786, según Cisco.

Las pruebas internas de Cisco también revelaron un problema crítico en su software IOS XE, CVE-2018-0150, debido a una cuenta de usuario no documentada que tiene un nombre de usuario y contraseña predeterminados. Cisco advierte que un atacante podría usar esta cuenta para conectarse de manera remota a un dispositivo que ejecuta el software.

La otra vulnerabilidad crítica CVE-2018-0151 es un error de ejecución remota de código en el subsistema QoS de IOS e IOS XE. "La vulnerabilidad se debe a la comprobación incorrecta de ciertos valores en paquetes que están destinados al puerto UDP 18999 de un dispositivo afectado. Un atacante podría aprovechar esta vulnerabilidad enviando paquetes maliciosos a un dispositivo", escribe Cisco.

Los tres errores recibieron una puntuación CVSS de 9.8 de 10. Embedi ha publicado una PoC, por lo que probablemente sea urgente que los administradores instalen el parche.

Este es el primer paquete de parches semestrales de Cisco para 2018 para IOS e IOS XE e incluye soluciones para un total de 22 vulnerabilidades para su sistema operativo de redes. Los 19 errores restantes IOS e IOS XE se clasifican como de alto impacto.

Fuente: ZDNet

0 comentarios:

Publicar un comentario

Gracias por dejar un comentario en Segu-Info
Si vas a dejar una consulta, procura tener habilitado tu perfil en Blogger o deja una forma de contacto.

Gracias por comentar!