23 dic. 2010

Exploit para una vulnerabilidad 0-Day en Internet Explorer

Ha sido publicado un exploit para una vulnerabilidad en Internet Explorer que posibilita la ejecución de código remoto. Hasta el momento Microsoft no ha publicado ningún parche, por lo que todos los usuarios son vulnerables.

La vulnerabilidad es provocada por un error en el motor de renderizado HTML de Internet Explorer (mshtml.dll) al manejar hojas de estilo .CSS. Un atacante puede explotarlo para ejecutar código y evadir las características de seguridad “Data Execution Prevention” (DEP) y “Address Space Layout Randomisation” (ASLR).

Hay reportes que indican que el exploit se vió por primera vez en ChinaMetasploit ya ha publicado el código del exploit y Abysssecya han publicado un video con la demostración de la explotación.

Investigadores de la compañía de seguridad VUPEN ha comprobado que la vulnerabilidad puede ser explotada en Internet Explorer 8 en Windows 7, Vista SP2 y XP SP3 así como en Internet Explorer 7 y 8 sobre Windows XP SP3.

Microsoft ha dicho que están investigando el fallo, pero no se ha anunciado el lanzamiento de un parche. Por ahora es recomendable tener habilitado el modo protegido de Internet Explorer 7 y 8 para limitar el impacto de los ataques.

Fuente: Open Security, ZDNET y Offensive Security

0 comentarios:

Publicar un comentario

Gracias por dejar un comentario en Segu-Info.

Gracias por comentar!