7 ago. 2016

Actualizaciones para diversos dispositivos Cisco

Cisco ha publicado siete boletines de seguridad para solucionar otras tantas vulnerabilidades en múltiples productos que podrían permitir a atacantes provocar condiciones de denegación de servicio, ejecutar código arbitrario, inyectar comandos Shell o acceder a routers sin autorización.

Los productos afectados son routers RV110W, RV130W, RV215W, RV180 VPN y RV180W Wireless-N Multifunction VPN, Cisco Unified Communications Manager IM and Presence Service, Cisco TelePresence Video Communication Server Expressway y Cisco Prime Infrastructure.

El primer problema, con CVE-2016-6397, se debe una vez más a la inclusión de una contraseña estática por defecto, esto puede permitir a un atacante remoto autenticarse en el dispositivo. Esta vez la cuenta afectada es la cuenta por defecto a la que además se le asignan permisos de root.

Este problema afecta a los siguientes productos:
  • RV110W Wireless-N VPN Firewall
  • RV130W Wireless-N Multifunction VPN Router
  • RV215W Wireless-N VPN Router
Estos mismos dispositivos, se ven afectados por una vulnerabilidad (con CVE-2015-6396) en la interfaz de línea de comandos que podría permitir a un atacante local inyectar comandos Shell arbitrarios que serán ejecutados por el dispositivo, con permisos de administrador.
Cisco ha publicado las siguientes versiones de firmware que corrigen ambos problemas.
  • RV110W Wireless-N VPN Firewall, Release 1.2.1.7
  • RV130W Wireless-N Multifunction VPN Router, Release 1.0.3.16
  • RV215W Wireless-N VPN Router, Release 1.3.0.8
Otras dos vulnerabilidades afectan a routers Cisco RV180 VPN Router y Cisco RV180W Wireless-N Multifunction VPN. En ambos casos los problemas residen en la interfaz web de los dispositivos.Con CVE-2016-1430, una validación inadecuada de las entradas en peticiones http podría permitir a un atacante remoto sin autenticar ejecutar comandos arbitrarios con privilegios de root. Por otra parte, con CVE-2016-1429, una falta de verificación adecuada y filtrado de la ruta de directorio introducida por el usuario podría permitir a un atacante remoto sin autenticar acceder a archivos arbitrarios del sistema mediante una escala de directorios.

Cisco no ha publicado, ni publicará, actualizaciones del firmware de estos dispositivos, debido a que ambos productos ya no están soportados.

Cisco también confirma una vulnerabilidad (con CVE-2016-1466) en Cisco Unified Communications Manager Instant Messaging (IM) y Presence Service por una validación inadecuada de las cabeceras de paquetes SIP (Session Initiation Protocol). El problema podría permitir a un atacante remoto sin autenticar que el reinicio del proceso del demonio Cisco SIP Proxy Daemon (sipd), lo que permitiría provocar condiciones de denegación de servicio.

Afecta a Cisco Unified Communications Manager IM and Presence Service versiones 9.1(1) SU6, 9.1(1) SU6a, 9.1(1) SU7, 10.5(2) SU2, 10.5(2) SU2a, 11.0(1) SU1 y 11.5(1).

Cisco ha publicado las siguientes versions que corrigen el problema:
  • Versión 11.5(1) SU1 para versión 11.5(1)
  • Cisco Optional Package ciscocm.cup-psirt-sipd-1101-v1.1.cop.sgn para versiones 11.0(1)
  • Cisco Optional Package ciscocm.cup-psirt-sipd-1052-v1.1.cop.sgn para versiones 10.5(2)
  • Cisco Optional Package ciscocm.cup-psirt-sipd-911SU-v1.1.cop.sgn para versiones 9.1(1)
Que pueden descargarse desde http://www.cisco.com/cisco/software/navigator.html:

Customers can download software for the Cisco Unified Communications Manager IM Products > Unified Communications > Unified Communications Applications > Presence Software > Unified Communications Manager IM & Presence Service.

Otra vulnerabilidad (con CVE-2016-1468) reside en la interfaz de administración web de Cisco TelePresence Video Communication Server Expressway, debido a un filtrado inadecuado de las entradas del usuario a los scripts del sistema afectados. Esto podría permitir a un atacante remoto sin autenticar ejecutar comandos arbitrarios en los sistemas afectados.

Se ven afectados los sistemas Cisco TelePresence Video Communication Server Expressway versión X8.5.2.

Cisco ha publicado actualizaciones para corregir el problema, disponibles desde https://tools.cisco.com/bugsearch/bug/BUGID

Por último, una vulnerabilidad (con CVE-2016-1474) en la interfaz web de Cisco Prime Infrastructure debido a una protección de iframe html insuficiente, que podría permitir a un atacante remoto sin autenticar realizar ataques Cross-Frame Scripting (XFS).

Los ataques de Cross-Frame Scripting (XFS) no dejan de ser un método para explotar los ya conocidos Cross-Site Scripting (XSS). En un atacante XFS, el atacante aprovecha un fallo específico para acceder a datos privados de un tercer sitio web. El atacante induce al usuario a acceder a una página web controlada por él; la página del atacante carga una página de un tercero en un frame HTML; y entonces mediante la ejecución de JavaScript en la página del atacante puede robar datos de la página del tercero.

Cisco ha publicado actualizaciones para corregir el problema, disponibles desde https://tools.cisco.com/bugsearch/bug/BUGID

Fuente: Hispasec

0 comentarios:

Publicar un comentario

Gracias por dejar un comentario en Segu-Info
Si vas a dejar una consulta, procura tener habilitado tu perfil en Blogger o deja una forma de contacto.

Gracias por comentar!