13 jul. 2015

Vulnerabilidad en OpenSSH <= 6.8 y BIND 9.X

Se ha encontrado una vulnerabilidad de seguridad en OpenSSH <= 6.8 que permitiría a servidores maliciosos saltarse algunas restricciones de seguridad X11. La vulnerabilidad ha sido identificada como CVE-2015-5352.

Después de que un cliente se conecta a un servidor X, es necesario autenticarlo. Esto se puede hacer especificando información de autenticación explícita: en la práctica, esto generalmente significa utilizar MIT-MAGIC-COOKIE-1, que requiere al usuario una "cookie" de autenticación al servidor. Pero, también puede hacerse implícitamente: por ejemplo, para una conexión local, el servidor podría dejar ingresar cliente basándose sólo en su UID.

Curiosamente, el servidor X realiza de nuevo una autenticación implícita, incluso si el cliente ha especificado explícitamente datos de autentificación no válidos. Hace unos días, OpenSSH ha publicado la versión 6.9 que soluciona la vulnerabilidad y es recomendable actualizar inmediatamente.

Además, ISC ha liberado una nueva versión del servidor DNS BIND. Esta versión corrige un error que podría causar una denegación de servicio a través de una consulta especialmente manipulada.

El problema, con CVE-2015-4620, afecta a servidores BIND configurados para realizar validaciones DNSSEC.Se ven afectadas las versiones BIND 9.7.1 a BIND 9.7.7, 9.80 a 9.8.8, 9.9.0 a 9.9.7 y 9.10.0 a 9.10.2-P1.

Fuente: Jann Horn e Hispasec

0 comentarios:

Publicar un comentario

Gracias por dejar un comentario en Segu-Info
Si vas a dejar una consulta, procura tener habilitado tu perfil en Blogger o deja una forma de contacto.

Gracias por comentar!