16 abr. 2015

Chrome 42: desactiva por defecto Java y otros plugins

Google Chrome en su versión 42.0.2311.90, ha terminado por cumplir lo que ya había anunciado: finalmente, se ha deshabilitado el soporte para plugins NPAPI, entre los cuales se encuentran algunos reconocidos como Netscape, Java y Silverlight.

Esta versión, además de presentar 45 actualizaciones de seguridad, implementa el esperado nuevo sistema de notificaciones push, que llegará para darle un importante empujón a las aplicaciones web.

Esta última actualización, como ya anunció Google hace tiempo, se ha deshabilitado la API que utilizaban anteriormente los plugins. Este cambio afecta a los plugins NPAPI, mientras que los más recientes PPAPI funcionan a la perfección, como es el caso de Adobe Flash, entre otros.

En la versión justo anterior, Google permitía a los usuarios habilitar, de forma manual, la compatibilidad con este tipo de plugins. Sin embargo, con este último lanzamiento se ha deshabilitado por completo el soporte para plugins NPAPI. Sin embargo, se desconoce aún si los navegadores web basados en Chromium seguirán la estela de Google Chrome en sus próximas actualizaciones, o bien continuarán un camino paralelo. Por otra parte, se contempla también que estos últimos apuren el plazo durante algunas semanas más, lo que sería conveniente para dar tiempo a adaptarse a los desarrolladores.

Además, pensando especialmente en los dispositivos móviles, Google ha lanzado una nueva API para su plataforma web con la que las webapps podrán ejecutar notificaciones push, de manera que ganarán una de las características más importantes para que su experiencia sea parecida a la de las aplicaciones nativas.

¿Qué hago si mis plugins no son compatibles con Google Chrome?

Como adelantábamos, hasta ahora habíamos podido habilitar el soporte para plugins NPAPI de forma manual. Ahora bien, con este nuevo lanzamiento, Google Chrome 42, la compañía de Mountain View no lo permite. Por lo tanto, las dos únicas opciones que tenemos actualmente son optar por plugins alternativos que sí sean compatibles, o bien cambiar a otro navegador web, como por ejemplo Firefox, de Mozilla.

Fuente: ADSLZone, Genbeta

0 comentarios:

Publicar un comentario

Gracias por dejar un comentario en Segu-Info
Si vas a dejar una consulta, procura tener habilitado tu perfil en Blogger o deja una forma de contacto.

Gracias por comentar!