27 nov. 2014

Error 0x80248015: Microsoft Update no funciona en Windows 2000/XP/2003

Las causas del problema siguen siendo una incógnita, pero los síntomas son bastante claros. A partir del 18 de noviembre, algunos Server 2003, Windows Home Server 2003 y equipos con Windows XP SP3 de repente se negaron a conectarse a Microsoft Update. Microsoft aún no ha respondido oficialmente al problema pero con el tiempo han aparecido soluciones alternativas.

Tenga en cuenta que, a pesar de que Windows XP ya no es compatible, las actualizaciones para Security Essentials en XP siguen pasando por Microsoft Update, y aún todos los anteriores parches para XP están todavía disponibles (cuando Microsoft Update está funcionando).

El hilo principal en TechNet sobre el tema dice que el error se ve así:
El sitio web ha detectado un problema y no puede mostrar la página que está intentando acceder. Las opciones que aparecen a continuación pueden ayudarle a resolver el problema.
Número de error: 0x80248015
También hay largas discusiones en SANS Internet Storm Center y en el sitio de MSFN.

Algunas personas han informado que simplemente ajustando el reloj del sistema a un par de semanas atrás y volviendo a ejecutar la actualización, el problema se soluciona. Para la mayoría, sin embargo, este enfoque no funciona.

Las alternativas van desde la eliminación de la carpeta C:\WINDOWS\SoftwareDistribution a ejecutar wuauclt.exe /detectnow.

En un post de Steve en el hilo de SANS ISC señaló un detalle importante: en las máquinas que reciben el error, cuando nos fijamos en los archivos C:\WINDOWS\SoftwareDistribution\AuthCabs\muauth.cab y C:\WINDOWS\SoftwareDistribution\AuthCabs\authcab.cab ves una entrada sospechosa:

[expirydate]2014-11-17T17:27:43.5251853-08:00[/expirydate]

Eso sucedió coincidiendo, más o menos cuando comenzó a fallar Microsoft Update .

En un un par de máquinas que aún están trabajando muy bien, y el archivo authcab.cab en ellos tiene esta entrada:
[expirydate]2018-06-01T17:27:43.5251853-08:00[/expirydate]
El archivo muauth.cab tiene:
2014 [expirydate][/expirydate]

No se sabe porqué el archivo authcab.cab en algunas máquinas tiene la fecha 2014, mientras que en otras tiene la fecha del 2018. Pero esto puede ser la diferencia que delatan que todavía las maquinas aún se pueden conectar a Microsoft Update y otras no lo puedan hacer.

El post de b3270791 en el hilo de MSFN tiene una solución que parece funcionar, pero se trata de sustituir los archivo muweb.dll y MicrosoftUpdateCatalogWebControl.dll en las máquinas con el problema con un archivo muweb.dll (versión 7.6.7600.256) y MicrosoftUpdateCatalogWebControl.dll (versión 7.4.7057.248) descargados desde Internet. Mientras que el enfoque no presenta exactamente las mejores prácticas de seguridad a nivel mundial, parece que funciona.

Los administradores de Server 2003 han estado cruzados de brazos por una semana, ya que no pueden instalar los parche de noviembre y en especial la actualización fuera de banda MS14-068. Los usuarios de XP se ven afectados, también, pero ¿a quién le importa? Microsoft debe respetar su promesa de entregar actualizaciones para Security Essentials a los clientes de XP.

Fuente: Foro Spyware y Infoworld

0 comentarios:

Publicar un comentario

Gracias por dejar un comentario en Segu-Info
Si vas a dejar una consulta, procura tener habilitado tu perfil en Blogger o deja una forma de contacto.

Gracias por comentar!