26 nov. 2019

ATFuzzer: interceptar comunicaciones en Android a través de BlueTooth [Paper]

Investigadores de la Universidad de Purdue y Iowa han descubierto que varios teléfonos Android populares pueden ser engañados para espiar a sus propietarios. Los atacantes pueden usar ese acceso para engañar a los teléfonos vulnerables para que renuncien a sus identificadores únicos, como sus números IMEI e IMSI, degradar la conexión de un objetivo para interceptar llamadas, desviar llamadas a otro teléfono o bloquear todas las llamadas telefónicas y el acceso a Internet por completo.

El equipo de investigación es, en su mayoría, similar al mismo que ha publicado el artículo 5GReasoner sobre las vulnerabilidaes en el protocolo 5G: Syed Rafiul Hussain, Imtiaz Karim, Fabrizio Cicala, Elisa Bertino de Purdue University, y Omar Chowdhury de University of Iowa.

La investigación, compartida exclusivamente con TechCrunch, afecta al menos a 10 dispositivos Android populares, incluidos Pixel 2 de Google, Nexus 6P de Huawei y Galaxy S8+ de Samsung.

Las vulnerabilidades se encuentran en la interfaz utilizada para comunicarse con el firmware baseband, el software que permite que el módem del teléfono se comunique con la red celular para hacer llamadas telefónicas o conectarse a Internet. Dada su importancia, la banda base generalmente está fuera del alcance del resto del dispositivo, incluidas sus aplicaciones, y a menudo viene con listas negras de comandos para evitar que se ejecuten comandos no críticos. Pero los investigadores descubrieron que muchos teléfonos Android permiten que los accesorios Bluetooth y USB, como auriculares accedan a la banda base. Al explotar un accesorio vulnerable, un atacante puede ejecutar comandos en un teléfono Android conectado.
"El impacto de estos ataques va desde la exposición de información confidencial del usuario hasta la interrupción completa del servicio", dijeron Syed Rafiul Hussain e Imtiaz Karim, dos coautores de la investigación, quienes presentarán su trabajo el próximo mes en la conferencia ACSAC 2019.

El firmware acepta comandos especiales, conocidos como comandos AT, que controlan las funciones celulares del dispositivo. Estos comandos se pueden usar para decirle al módem a qué número de teléfono llamar. Pero los investigadores encontraron que estos comandos pueden ser manipulados. Los investigadores desarrollaron una herramienta, llamada ATFuzzer, que trata de encontrar comandos AT potencialmente problemáticos.

En sus pruebas, los investigadores descubrieron 14 comandos que podrían usarse para engañar a los teléfonos Android vulnerables para que filtren datos sensibles del dispositivo y manipulen las llamadas telefónicas.

Pero no todos los dispositivos son vulnerables a los mismos comandos o pueden manipularse de la misma manera. Los investigadores descubrieron, por ejemplo, que ciertos comandos podrían engañar a un teléfono Galaxy S8+ para que filtre su número IMEI, redirigir las llamadas telefónicas a otro teléfono y degradar su conexión celular, todo lo cual puede usarse para espiar y escuchar llamadas telefónicas, como lo hace el hardware especializado en espionaje conocido como "stingrays". Otros dispositivos no eran vulnerables a la manipulación de llamadas, pero eran susceptibles a comandos que podrían usarse para bloquear la conectividad a Internet y las llamadas telefónicas.

Las vulnerabilidades no son difíciles de explotar, pero requieren que se cumplan todas las condiciones correctas. "Los ataques pueden ser llevados a cabo fácilmente por un adversario con conectores Bluetooth baratos o mediante la instalación de una estación de carga USB maliciosa", dijeron Hussain y Karim. En otras palabras, es posible manipular un teléfono si se puede acceder a un accesorio a través de Internet, como una computadora. O, si un teléfono está conectado a un dispositivo Bluetooth, un atacante debe estar muy cerca.

"Si su teléfono inteligente está conectado con un auricular o cualquier otro dispositivo Bluetooth, el atacante primero puede explotar las vulnerabilidades inherentes de la conexión Bluetooth y luego inyectar esos comandos AT malformados", dijeron los investigadores.

Samsung reconoció las vulnerabilidades en algunos de sus dispositivos y está implementando parches. Huawei no hizo comentarios y Google dijo: "Los problemas informados cumplen con la especificación Bluetooth o no se reproducen en dispositivos Pixel con parches de seguridad actualizados".

A lo largo de los años ha habido varios documentos que examinan varios teléfonos y dispositivos con vulnerabilidades de banda base. Aunque estos informes son poco frecuentes, los investigadores de seguridad han advertido durante mucho tiempo que las agencias de inteligencia y los delincuentes informáticos podrían estar utilizando estos defectos para lanzar ataques silenciosos.

Hussain dijo que los iPhones no se ven afectados por las vulnerabilidades.

Fuente: TechCrunch

0 comentarios:

Publicar un comentario

Gracias por dejar un comentario en Segu-Info
Si vas a dejar una consulta, procura tener habilitado tu perfil en Blogger o deja una forma de contacto.

Gracias por comentar!